Community Groups are officially here!
We've released Groups, a new feature that enables us to connect community members of similar industries and interests in a shared, private space. You can check out all of the details here, including information about who can join, how to join, and what Groups are currently offered. Please leave your feedback through this Community Groups Feedback Survey.

Custom End of Survey message overridden by default end of survey message

Carmen_v1
Carmen_v1 Melbourne, AustraliaCommunity Member Qubie ✭
edited July 28 in Survey Platform

Hi there, am a real new Qubie here!

I've set up a customised end of survey message but it's not taking effect. Have tried various ways but with no luck. Have used the Survey Builder and the Survey Flow, but still the default appears.

Is anyone able to perhaps guide me through this please?

Best Answers

  • [Deleted User]
    [Deleted User] Qubie ✭
    Accepted Answer

    Hello @Carmen_v1 ,

    Please follow this page
    and this thread

    Also this page

    It will be good for us to understand if you provide more inputs on exactly how you are customizing EOS

  • VirginiaM
    VirginiaM Boone, North CarolinaCommunity Member Sage ✭✭✭
    Accepted Answer

    @Shashi I see what you mean!
    @Carmen_v1 have you tried only having the customized end of survey message in the survey flow and not both the flow and options? I wonder if they're "competing" with each other... To test this, I went in the .qsf and changed both to a different end-of-survey message and the one I got at the end was from the survey flow, not options. So I tried setting the options back to default and I still go the custom end of survey message from the flow. I'd be interested to hear if this works for you too!

  • NiC
    NiC MumbaiCommunity Member, XMPN Member, Qualtrics Brand Admin Superuser ✭✭✭✭
    Accepted Answer

    Hi @Carmen_v1
    when i tried the qsf file you shared and when i set a custom message it worked just fine for me and i could see that it was set to a custom message. I think it might just be glitch , if you can delete your survey and try importing your own qsf file . This has helped me with glitches that should not occur but do occur (this method was suggested to me by @PraDeepKotian_UGAM ) . Maybe it can help you too...

Answers

  • PeeyushBansal
    PeeyushBansal IndiaCommunity Member, XMPN Member, Qualtrics Brand Admin Wizard ✭✭✭✭✭

    1.) Click on customize in end of survey element in survey flow.
    2.) click on override survey option.
    3.) click on customized end of survey message.

    There you can save your message.

    For different terminations you can show different end of survey messages.

  • Carmen_v1
    Carmen_v1 Melbourne, AustraliaCommunity Member Qubie ✭

    Hi Shashi,

    Thank you for your reply. I have previously looked at those pages and followed the instructions to set up the custom end of survey message in both the Survey Builder and Survey Flow but all that appears at the end of the survey is 'We thank you for your time spent taking this survey.
    Your response has been recorded.'

  • Carmen_v1
    Carmen_v1 Melbourne, AustraliaCommunity Member Qubie ✭

    @bansalpeeyush29 said:
    1.) Click on customize in end of survey element in survey flow.
    2.) click on override survey option.
    3.) click on customized end of survey message.

    There you can save your message.

    For different terminations you can show different end of survey messages.

    Thanks! But unfortunately this does not work. I have tried this as well but still getting the default message.

  • PeeyushBansal
    PeeyushBansal IndiaCommunity Member, XMPN Member, Qualtrics Brand Admin Wizard ✭✭✭✭✭

    can you attach your qsf flile.

  • Carmen_v1
    Carmen_v1 Melbourne, AustraliaCommunity Member Qubie ✭

    @bansalpeeyush29 said:
    can you attach your qsf flile.

    Yup, see attached. Thanks!

  • @Carmen_v1 said:

    @bansalpeeyush29 said:
    can you attach your qsf flile.

    Yup, see attached. Thanks!

    @Carmen_v1 can you see the EOS message in the message library section

  • Carmen_v1
    Carmen_v1 Melbourne, AustraliaCommunity Member Qubie ✭

    @Shashi said:

    @Carmen_v1 said:

    @bansalpeeyush29 said:
    can you attach your qsf flile.

    Yup, see attached. Thanks!

    @Carmen_v1 can you see the EOS message in the message library section

    Hi Sashi, yes I can. It appears under my personal library rather than the organisational one. Could that be an issue?

  • @Carmen_v1 said:

    @Shashi said:

    @Carmen_v1 said:

    @bansalpeeyush29 said:
    can you attach your qsf flile.

    Yup, see attached. Thanks!

    @Carmen_v1 can you see the EOS message in the message library section

    Hi Sashi, yes I can. It appears under my personal library rather than the organisational one. Could that be an issue?

    No, there is no issue with that then.

  • PeeyushBansal
    PeeyushBansal IndiaCommunity Member, XMPN Member, Qualtrics Brand Admin Wizard ✭✭✭✭✭

    For me on changing message it is appearing changed one. Can you analyze and publish and than use published version for checking.

  • VirginiaM
    VirginiaM Boone, North CarolinaCommunity Member Sage ✭✭✭

    @Carmen_v1 When I use the preview survey link in your .qsf I see the following end of survey message, which makes me think it's working correctly now:

  • @VirginiaM said:
    @Carmen_v1 When I use the preview survey link in your .qsf I see the following end of survey message, which makes me think it's working correctly now:

    That is just a question text not the EOS

  • Carmen_v1
    Carmen_v1 Melbourne, AustraliaCommunity Member Qubie ✭

    Thanks for your input everyone! I've tried all your suggestions and have come to the conclusion that it's a default setting for our organisation.

  • emilychai
    emilychai Community Member Qubie ✭

    I just called the Qualtrics support. Maybe the skip logic is overriding the customized message. I solved the problem by going to the survey builder page, and removing the "skip to" for the question. Then it works as expected.