Autoplay Video

MattGehr
MattGehr Athens, Georgia Community Member Qubie ✭
edited July 29 in Custom Code

Hi everyone

I am having some trouble getting a video downloaded from my hard drive onto Qualtrics to autoplay properly. I have followed tutorials online and the part I am getting stuck on is enabling autoplay in the source code. I have tried finding autoplay = "false" in the source code and changing it to autoplay = "true" and I have tried adding "?autoplay=1" to the end of the video identifier. Additionally, even when I have uploaded the video from my library and added the "?autoplay=1" to the end of the URL it still does not work. This is probably a simple explanation but I am at a loss and working on a deadline so any help would be appreciated. Below is the source code and the URL for the video

Source:

URL: https://ugeorgia.ca1.qualtrics.com/CP/File.php?F=F_9Miz0bR8KvsdXgh?autoplay=1

Best Answer

  • ahmedA
    ahmedA IndiaCommunity Member, XMPN Member Wizard ✭✭✭✭✭
    Accepted Answer

    Thankfully media will NOT autoplay without the user first interacting with the webpage, therefore, if you want to it to autoplay, add it on page 2 and have some questions on page 1.

Answers

  • Agnieszka
    Agnieszka Warsaw, PolandCommunity Member Qubie ✭

    Hello,

    I have the same issue - I tried all of these steps but my video still does not play. It seems like the code change (to autoplay = "true") doesn't work.

    Also, when I'm changing "src=" by adding "?autoplay=1" or "?&autoplay=1" in HTML view my video turns black and has zero seconds.

    Matt, did you solve the problem? Maybe someone else has an idea? I will be grateful for your help, my master's thesis is suffering!

  • RutStu
    RutStu NetherlandsCommunity Member, Qualtrics Brand Admin Qubie ✭

    I have the same issue... within the editor the autoplay does work, but as soon as I check the video in preview mode or published mode there is no autoplay. Did you manage to solve the issue?

  • pbado
    pbado Rio de JaneiroCommunity Member Qubie ✭

    Hi everyone, I have a similar problem. Autoplay (?autoplay=1 after video link) does work within the editor and in preview mode but not on published mode.

    Did someone manage to find the solution? Thanks!

Sign In to Comment

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!