Community Groups are officially here!
We've released Groups, a new feature that enables us to connect community members of similar industries and interests in a shared, private space. You can check out all of the details here, including information about who can join, how to join, and what Groups are currently offered. Please leave your feedback through this Community Groups Feedback Survey.

Connecting with Google Sheets and Google Drive

2»

Answers

  • AmieLin
    AmieLin Chicago Qubie ✭

    Did anyone ever figure out a work-around for this error? I can't seem to get past this point:

    "name": "ACTIONS.ERROR_CODES.USER_CONFIGURATION_ERROR",
        "message": "Exceeded max limit of redirects",
        "needRetry": false
    


  • kerwick
    kerwick Auckland,New Zealand Qubie ✭

    make sure your google sheets headers match that of the variables your are sending

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭

    I did always get the same error message until a week ago - now I have:

    "name": "ACTIONS.ERROR_CODES.USER_CONFIGURATION_ERROR",
        "message": "Exceeded max limit of redirects",
        "needRetry": null
    

    and it seems as needRerty is now null, qualtrics keep calling the script... so the data is now published 4 times...

  • kerwick
    kerwick Auckland,New Zealand Qubie ✭

    Yes it works but published 4 times each time. I have not found a solution to this yet

  • This script was a life saver for us and unfortunately...we just went live with our qualtrics survey and my users are all bent out of shape over having quadruplicates of all data. I checked out the post referenced above but unfortunately that doesnt help alot of us. anyone know of a way to either change this response back to false from google which was harmless or a new way to run these requests?

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭

    yet still coming x4.

    Still using the script, but now I have in my google sheet one tab with the raw data from the script (x4) then another tab where I use the function "Unique" from google to pull the data...

    not a dream but it works...

  • mklubeck
    mklubeck South Bend, Indiana Sage ✭✭✭

    @Chaps85 You might have noticed by now that they have fixed the x4 copies! And they are also testing an auto integration with sheets and Calendar

  • mklubeck
    mklubeck South Bend, Indiana Sage ✭✭✭

    @mwandler You might have noticed by now that they have fixed the x4 copies! And they are also testing an auto integration with sheets and Calendar

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭

    Looks like Qualtrics made some changes in the WebService - it was working until I open the actions and since the action is not trigger and it looks it changed from JSON and before it was "URL Encoded" :-(

    HELP

  • mklubeck
    mklubeck South Bend, Indiana Sage ✭✭✭

    @Chaps85 I'm sorry, I don't understand what you wrote.

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭

    Ooops sorry - I was on panic mode yesterday - still am but ready to face the challenge!

    So typically Qualtrics made some changes in webservice recently... when you create a new one action, it looks totally different than when this post was created.

    The webservice action was still working until I open the action to edit (I added a variable).

    It looks when you open the action, Qualtrics automatically added Headers "application/json" and in body change to json:

    I tried to changed key-value pairs to URL Encoded as the documentation in this post suggested:

    But it's now showing: task setup is incomplete :-(

    and nothing trigger.

    When I use JSON, it looks it triggers but empty value (just space).

  • mklubeck
    mklubeck South Bend, Indiana Sage ✭✭✭

    Hmm.

    Not sure. But their new integration with Sheets (which will make the script obsolete) is looking to be released in July. Can you wait or do you need this before then?

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭

    July is long time :-)

    I was able to do the api in survey flow instead of actions and it worked...

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭

    Do we know when the google integration from Qualtrics will be live? They mentioned July a few months ago but no more news since...

  • JenniferAKWells
    JenniferAKWells Forest Grove, Oregon, USA Qubie ✭

    I just tried this and had the same "This task is setup is incomplete" error message. Also, I tried to add it at the end of the survey flow with no luck, but it's possible I missed a step there.

    Anyone have updates on Google integration?

  • mklubeck
    mklubeck South Bend, Indiana Sage ✭✭✭

    @JenniferAKWells and @Chaps85 The integration is live now. You should no longer need to use the scripts. I looked, but couldn't find a help article on it though. It should be in Actions,


  • JenniferAKWells
    JenniferAKWells Forest Grove, Oregon, USA Qubie ✭

    @mklubeck Thanks! It's not showing up as an option for me in that window, so there may be something about how my institution has things configured/pays for whatever. I'll investigate with our tech team.

    Excited to see this integration, though!

  • mklubeck
    mklubeck South Bend, Indiana Sage ✭✭✭

    @JenniferAKWells yes, check with your brand admin...it should have been released for General Audiences (GA) already.

  • Chaps85
    Chaps85 Auckland, nz Qubie ✭
    edited August 18

    thanks @mklubeck you made my day!!!!

    (Just checking you are not under preview/testing license?)

    Still don't have access although under the right license...