Changing size of scale point images bipolar scale | XM Community
Question

Changing size of scale point images bipolar scale

  • 27 February 2024
  • 3 replies
  • 15 views

Badge +1

I am trying to make a bivariate valence scale using the matrix table option in a survey. I want to use images as scale points. In the survey builder mode, the images appear in the correct size, like this:

 


However, when I view the published survey, the images appear extremely small, like this:

 

Even when I adjust the size by adjusting the code, the images stay the same size in the published survey. Does anyone have any experience with correcting this? Or any advice for another approach that I could use?

 

Many thanks!


3 replies

Userlevel 6
Badge +20

Hello @chrisams

I'm not sure which code you're referring to, but I recommend trying the following steps:

1. Add all images to your library.
2. Incorporate a Matrix question into the survey.
3. Next, click on 'Choice text,' then select the dropdown menu, followed by 'Rich content editor,' and finally 'insert graphic.'
4. Repeat step 3 for each choice and add an image to all options.
5. You can adjust the size of the images either in the Library or directly in the survey. Simply click on the image, choose the dropdown menu, select 'Rich content editor,' and double-click on the image to make size adjustments.

Hope this helps!

Badge +1

Hi @Sachin Nandikol , thanks for your quick response. I've followed your instructions (although cannot find the "choice text” function. Unfortunately, although adjusting the image size in the rich content editor results in the image being enlarged in the survey builder mode, like so:

 

 

When I preview the survey, the images remain exactly the same size, like so:

No idea why the size adjustment is not translated to the actual survey in the end. Any ideas?

Userlevel 6
Badge +20

Hello @chrisams ,

The "choice text" refers to the area where you've inserted your image. If you notice your image is being enlarged, you can adjust its size as outlined in my previous suggestion. Before previewing your survey, ensure that you have "Published" it, and check for any added code that might be causing this issue.

Additionally, I recommend creating a copy of your survey and removing any code you added to adjust the size. Follow my instructions precisely without adding any code, then try again.

Leave a Reply