Community Groups are officially here!
We've released Groups, a new feature that enables us to connect community members of similar industries and interests in a shared, private space. You can check out all of the details here, including information about who can join, how to join, and what Groups are currently offered. Please leave your feedback through this Community Groups Feedback Survey.

Expired Link error - but it hasn't?

LTaylor
LTaylor MECommunity Member Qubie ✭
edited July 30 in Survey Platform

Hi all,

One of my users is getting the expired link error when clicking a personalised link. The link isn't due to expire until 2099, and the survey is not showing in the recorded responses list or the responses in progress list.
When looking at the distribution list again, there is no Response ID next to the link, so I would assume it hasn't even been clicked yet. However, that is definitely the link that they have.

I've tried it myself and get the same error, so I don't think it's a browser issue.

Any advice would be much appreciated!

Comments

  • PeeyushBansal
    PeeyushBansal IndiaCommunity Member, XMPN Member, Qualtrics Brand Admin Wizard ✭✭✭✭✭

    Hi @ltaylor

    Read below for error code EQD15, it might helps you to detect what is wrong with link:

    https://www.qualtrics.com/support/survey-platform/distributions-module/email-distribution/email-distribution-error-messages/

  • LTaylor
    LTaylor MECommunity Member Qubie ✭

    @bansalpeeyush29 said:
    Hi @ltaylor

    Read below for error code EQD15, it might helps you to detect what is wrong with link:

    https://www.qualtrics.com/support/survey-platform/distributions-module/email-distribution/email-distribution-error-messages/

    Thanks @bansalpeeyush29
    I've been through that, and it's not any of the three things it suggests.

    • The link was created to expire in 2099
    • The survey doesn't have an expiration date
    • The survey won't record partial completions until this time next year, and it's not in the recorded responses list, or the responses in progress list.

    I'm so puzzled....

  • PeeyushBansal
    PeeyushBansal IndiaCommunity Member, XMPN Member, Qualtrics Brand Admin Wizard ✭✭✭✭✭

    In that case i think you need to contact support team, they may better help on this.

  • KendraR
    KendraR Provo, UTModerator, Community Member, Qualtrics Brand Admin Moderator

    Hi, @LTaylor! There are various reasons for seeing the expired link error, and every use case is different! We see that you've reached out to our Support Team about your specific use case, which may be related to a change in project ownership or contact list deletion. If you have any additional questions, be sure to reach back out to the support representative you were previously working with! :smiley:

  • vikingprofessor
    vikingprofessor Long BeachCommunity Member Qubie ✭

    Same problem. I'm the creating of the project so ownership so not be a problem. I also created the contact list just for this particular survey. I have reached out to support to see what the issue is. Disappointed this turned out to be much more complicated than it needs to be.

  • Amachamer
    Amachamer San JoseCommunity Member, Qualtrics Brand Admin Qubie ✭

    In my case, i copied a previous survey and renamed it. But I did not change the expiration settings. If that sound similar to your situation go to "Survey Options". Scroll down the pop-up to "Survey Expiration" There you can reset the date. After I saved the new information I then had to publish the survey.

  • Geoff0534
    Geoff0534 United KingdomCommunity Member Qubie ✭

    great answer - exactly what's needed

  • TimVG
    TimVG New South Wales, AustraliaCommunity Member, XMPN Member, Qualtrics Brand Admin Qubie ✭

    Thanks for the guidance, this helped. Turns out my Survey has a FIRM expiry date (2 months ago). So went to Survey - Options - Responses - under the heading 'Survey availability' I selected 'leave survey open'. Then when distributing I chose my preferred expiry (eg. 60 days).