Panel Company Integration Issue

AaronG
AaronG Vancouver, British Columbia, Canada Qubie ✭
edited April 2020 in Integrations

I'm currently trying to implement a complete response link for our third party sample provider. They've provided me with a link https://surveys.ipsosinteractive.com/surveys/?id=${e://Field/Resp_ID}&Cortex_ID=${e://Field/Cortex_ID}&pid=${e://Field/Proj_ID}&stat=C that they say they've given to all their client who have used qualtrics. I've included a customized End of Survey block with the link included, as seen here:https://puu.sh/FsNAs/aa845f13a0.png. I've tried using multiple different embedded data sets, such as https://puu.sh/FsNCf/5cea1cba39.png, https://puu.sh/FsLFV/92d7feefdf.png and https://puu.sh/FsNEA/3893bf1681.png, however, each time I get the marketing company to test it, they say that it only retrieves the Cortex_ID. If anyone has any idea as to what the issue is here, I would be very appreciative.

Thanks

Tagged:

Answers

  • TomG
    TomG Raleigh, NC Wizard ✭✭✭✭✭

    What are the parameters in the url their respondents are using the access the survey?

  • AaronG
    AaronG Vancouver, British Columbia, Canada Qubie ✭

    From what I've been told it's Resp_ID, Cortex_ID and Proj_ID. I've tried setting the embedded data at the start to match that, but still have had no luck, where they are only receiving the Cortex_ID.

  • TomG
    TomG Raleigh, NC Wizard ✭✭✭✭✭
    edited April 2020

    If that is true, your first pic https://puu.sh/FsNCf/5cea1cba39.png, would be correct.

    Two suggestions:

    1. Add Q_URL as an embedded variable. That will capture the incoming parameters to see if they are what you think they are.
    2. Create a complete_url variable that contains the panel redirect (https://surveys.ipsosinteractive.com/surveys/?id=${e://Field/Resp_ID}&Cortex_ID=${e://Field/Cortex_ID}&pid=${e://Field/Proj_ID}&stat=C). Then pipe that into the end of survey block as ${e://Field/complete_url}. This will let you see exactly what is in your redirect. Plus, I think you'll generally find it easier, especially if you have multiple exit points.
  • AaronG
    AaronG Vancouver, British Columbia, Canada Qubie ✭

    Thanks for the feedback. I implemented the Q_URL and when I look at the data I got the following screenshot https://puu.sh/FsT7w/b385958d21.png, so from this, the id and pid variables are not correct, is that right?

    Sorry I'm fairly new to this, but how do I go about creating said variable, I've gotten to this page https://puu.sh/FsTrx/d74c4488e8.png, but I'm not sure if that's where I want to be. Also, where would I pipe it into the the end of survey block https://puu.sh/FsTjx/8a8d1b6baf.png, would I add a new element before the end of survey. I'm very sorry if these are basic questions, but I had to learn this overnight due to our previous platform being incompatible with redirects.

    Again, thanks for any help you can provide

  • TomG
    TomG Raleigh, NC Wizard ✭✭✭✭✭

    Your embedded data variables:

    Your end of survey:


  • AaronG
    AaronG Vancouver, British Columbia, Canada Qubie ✭

    Thanks for the instructions. I tried the above using the variables Resp_ID, Cortex_ID, and Proj_ID for the embedded data and got this https://puu.sh/FsUT0/b8dbcf39c4.png. I then tried changing the variables to id, Cortex_ID, and pid for the embedded data and got this https://puu.sh/FsUVe/b9280dc2b1.png.

    Neither of them could send the id or pid.

  • TomG
    TomG Raleigh, NC Wizard ✭✭✭✭✭

    Thanks for the instructions. I tried the above using the variables Resp_ID, Cortex_ID, and Proj_ID for the embedded data and got this https://puu.sh/FsUT0/b8dbcf39c4.png. I then tried changing the variables to id, Cortex_ID, and pid for the embedded data and got this https://puu.sh/FsUVe/b9280dc2b1.png.

    Neither of them could send the id or pid.

    Everything in your second screen shot is correct except the value of complete_url. So, you must have piped the values of id and pid incorrectly. It should be just like the image I posted above.

  • AaronG
    AaronG Vancouver, British Columbia, Canada Qubie ✭

    This is how I have it set, and the values I get. I've set it up identical to yours, but still only get the Cortex_ID. I don't know if the issue is with the link they sent me, because I'm able to retrieve the values they want. However, I've been told that other people have indeed received the same links and had it work.


  • TomG
    TomG Raleigh, NC Wizard ✭✭✭✭✭

    Your complete_url is wrong. The embedded variables are id and pid NOT Resp_ID and Proj_ID. In text so you can copy and paste:

    https://surveys.ipsosinteractive.com/surveys/?id=${e://Field/id}&Cortex_ID=${e://Field/Cortex_ID}&pid=${e://Field/pid}&stat=C
    
  • AaronG
    AaronG Vancouver, British Columbia, Canada Qubie ✭

    When I change the complete_url to that, I end up at this page

    Here's the data record that I get back though

    I feel like the issue may lie with the link they've provided me